Muutamia kysymyksiä PC ---> USB-DAC asetusten optimointiin

  • Keskustelun aloittaja L7R
  • Aloituspäivämäärä

L7R

Käyttäjä
Liittynyt
26.3.2008
Viestejä
11
Kaupunki
Tampere
Foorumeita lueskellessa törmäsin mielenkiintoiseen topikkiin jossa mainittiin:
THD sanoi:
Äänenvoimakkuuden digitaalinen (matemaattinen) säätö, varsinkin jos se tehdään riittämättömällä bittisyvyydellä (16), rikkoo myös audiodataa, eli kaikki volumesäätimet tappiin.

Tuo on uutta meikäläiselle. Putkivahvistimessani, jossa NOS-DAC 16bit/44KHz (Burr-Brown PCM2702) on balanssi lievästi (1-2db) vasemmalla potikan asennosta riippuen.

1. Vaikuttaako laatuun, kun joudun säätämään windowsissa äänenvoimakkuutta hivenen oikealle? Toinen kanava siis maksimilla ja vain toinen hieman vaimennettu. Soittimena Winamp josta äänenvoimakkuus disabloitu.

2. Olen myös aina luullut, että jos äänitiedosto on esim. 16bit/44.1 niin tällöin signaali matkaa muuttumatomana eteenpäin jos ei erikseen käytetä esim. ohjelmallista konversiota, tai erillistä äänikorttia (käsittääkseni joissain creativen tuottessa tehdään (pakko)konversio ennen antoa. Miten voin varmistaa ettei mitään konversioita tapahdu ennen antoa))?

3. Ja nyt kun vauhtiin pääsin, niin kysytään vielä että kumpaa kannattaa käyttää ulostulona winampissa ja windowsissa USB-DACin kanssa (tai ylipäätään); DirectSoundia vai WaveOutia? Entä bufferoinnin asetukset (core2duo/2GB/winXP)? Eli laite on plug&play ja asentuu äänilaitteisiin nimellä USB-Kaiuttimet.


ps. (4.) Ihmettelen kyllä kun DAC on tavallinen NOS-16bit, mutta syöttämällä sille uudelleensamplattuna esim. 96KHz/24bit FFDSHOW:n tai winampin Shibatch mpg123:n kautta, ääni kuuluu edelleen ongelmitta? Jopa 32bit integer toimii mutta 32bit float jumauttaa soittimen. Ihmeellisiä ovat tietotekniikan koukerot. =)
 

Musti sotakoira

Käyttäjä
Liittynyt
20.9.2007
Viestejä
239
1. Väittäisin, että vaikuttaa aivan samoin kuin äänenvoimakkuuden säätäminen ohjelmallisesti muutenkin.

2 & 3 Windowsin kmixerin outputti ei ole bittitarkka alkuperäisen äänen kanssa. Muunnoksia tapahtuu matkan varrella, eli ei Directsoundia, eikä waveoutia, vaan ASIO:ta. Asio-ajuri keskustelee suoraan raudan kanssa. Bittitarkkuuden lisäksi etuna on pienempi latenssi, jolla ei tosin kuuntelukäytössä ole juuri merkitystä. Jos äänikortille ei löydy asio-ajuria, kokeile ASIO4ALL-ajuria winamppiin. Foobarin kanssa voi käyttää myös kernel streaming-pluginiä, jolla saavutetaan ymmärtääkseni myös bittitarkka ulosanti.
 

L7R

Käyttäjä
Liittynyt
26.3.2008
Viestejä
11
Kaupunki
Tampere
Kiitokset vastauksesta. Asensin juuri ASIO4ALL:in ja winamp pluginin ja hyvin toimii. Olin kuvitellut että ASIO on tärkeä vain muusikoille ja musiikinkuunetelussahan latenssilla ei pitäisi olla merkitystä.
 
T

teekal

Mutta tietty kannattaa aina käyttää Asio ajureita jos mahdollista, varsinkin Windows käytössä. Kaikilla usb liitännäisillä daceilla se ei välttämättä onnistu kuitenkaan, silloin kannattaa noudattaa noita edellä mainittuja ohjeita. Itsekkin käytän kuitenkin edelleen Rme äänikortin Coax liintäntää digisignaalin siirtoon Asio:lla tietty.
 

Janne-ii

Hifiharrastaja
Liittynyt
25.12.2007
Viestejä
1 942
Kaupunki
Nokia
En nyt aloita uutta ketjua, kun liippaa läheltä.
Eli ostin tuossa uuden PC:n, jossa nyky muodin mukaan on tietenkin Vista.
Ongelma: entisen XP:ni kanssa moiteetta toiminut M-Audio Audiophile USB ei ota toimiakseen kunnolla, pitää siis hioa asetuksia. Eli mitä tehdä?
-Setti: Kannettava, jossa win Vista-> Foobar2k v0.9.5.2 (ASIO plugini käytössä) -> USB narulla kytkettynä M-Audion äänikortti-> Kuulokkeet.
Ääni ei ole niin hyvää tasoa kuin oli vanhan koneen ja xp:n kanssa? Toimiiko ASIO? vai mikä voisi olla?
 
M

Matti Lehtinen

Janne-ii sanoi:
Ääni ei ole niin hyvää tasoa kuin oli vanhan koneen ja xp:n kanssa? Toimiiko ASIO? vai mikä voisi olla?

En tiedä mutta veikkaan. :)

Elikkäs Windowsillahan on paha tapa resamplata lähtöihin sitä 48Khz - bittivirtaa, vai mitä se oli?

Elikkäs oletko vakoillut M-Audion sivuilta, jotta sinulla on varmasti uusimmat mahdolliset ajurit äänikortillesi Vistaa varten?

Jotta saisit varmuudella sitä natiivia bittivirtaa ulos siitä USB - liitännästä?
 

Janne-ii

Hifiharrastaja
Liittynyt
25.12.2007
Viestejä
1 942
Kaupunki
Nokia
Uusimmat ajurit latasin tänä aamuna, kun tuota kojetta asentelin uudelleen. Itse äänenlaatu on kyllä entisellä tasolla, mutta vaikka latenssit on nostettu tappiin (kaikkea kokeiltu minimin ja maksimin välillä), jopa kevyen netin surffailun aikana tapahtuu pätkimistä äänessä. Voimaa pitäisi koneessa olla kuin pienessä kylässä, ainakin jos vertaa vanhaan koneeseen? Missä vika. Siis vanhalla koneella ei tätä pätkimistä tapahtunut kuin todella pienillä latensseilla ja kovan kuormituksen aikana.
Kaikki Winukan omat äänilaitteet on ohitettu tai poistettu käytöstä, eli ainoa koneen tajuama äänilaite on tuo M-Audio, kiinni USB letkulla eli Winukan omien softien ei pitäisi vaikuttaa ääneen millään tavalla.
 

reali

Käyttäjä
Liittynyt
24.2.2008
Viestejä
181
Oletko koittanut eri soittimia / tapahtuuko niillä sama pätkiminen?
 

Janne-ii

Hifiharrastaja
Liittynyt
25.12.2007
Viestejä
1 942
Kaupunki
Nokia
En ole vielä, mutta todella mystinen ongelma on. Koska rasitus ei tunnukkaan olevan oikestaan syynä äänen pätkimiseen, vaan se kun clikkaa jotakin linkkiä netissä, tai vaikka vaihtaa sivua, aina kuuluu pieni ritsahdus.
 

Janne-ii

Hifiharrastaja
Liittynyt
25.12.2007
Viestejä
1 942
Kaupunki
Nokia
BTW kone taitaa pitää pienin niksahdus äänen nettiä käyttäessä, pitänee etsiä mistä sen saa pois päältä, se voisi aiheuttaa tuon...

Edittiä, sieltä se vika sitten löytyi, en muistanut tuota ääntä koska koneessa ei ollut mitään äänilähdettä, kunnes nyt.
 
T

teekal

http://extra.benchmarkmedia.com/wiki/index.php/Windows_Vista_Audio_Playback_-_Setup_Guide


Turn-off operating system sounds

* System sounds could compromise the quality of your audio (as well as being incredibly annoying!). They will interrupt bit-transparency and could cause clipping.



Janne-ii sanoi:
BTW kone taitaa pitää pienin niksahdus äänen nettiä käyttäessä, pitänee etsiä mistä sen saa pois päältä, se voisi aiheuttaa tuon...

Edittiä, sieltä se vika sitten löytyi, en muistanut tuota ääntä koska koneessa ei ollut mitään äänilähdettä, kunnes nyt.
 
Ylös